Worldwide Network Outage Affecting Azure, AWS, Google Cloud and more
Minor incident
Dashboard
US Dashboard
UK Dashboard
Portal
US Apply Portal
US Member Portal
UK Apply Portal
UK Member Portal
API
US Region
UK Region
REST
REST 2.0
2025-10-29 12:00 CDT
· 1 hour, 54 minutes
Updates
Resolved
October 29, 2025 · 13:53 CDT
We have mitigated the risk by removing our dependency on Microsoft Azure Front Door and their network. Everything should be operating back to normal.
Please note, Microsoft Azure still has a network outage that is recovering. It should have minimal impact on our platform due to our updates.
Issue
October 29, 2025 · 12:23 CDT
There is a global network outage with all Cloud Providers that are impacting access to certain elements.
For updates on Azure (our infrastructure) see:
https://azure.status.microsoft/en-us/status
← Back
Platform Availability