Email Delivery Delays

Minor incident Dashboard US Dashboard UK Dashboard
2025-04-23 16:58 CDT · 18 hours, 8 minutes

Updates

Resolved

SendGrid has confirmed a fix is in place and all systems should be fully operational.

April 23, 2025 · 20:06 CDT
Issue

Our email provider, SendGrid, has identified the issue affecting outbound email delivery. As a temporary measure to improve deliverability, SendGrid has bypassed checks against their Bounce Suppressions list. This means that emails sent to addresses previously marked as bounced may be delivered during this time.

We are actively monitoring the situation and will continue to provide updates as more information becomes available.

Thank you for your continued patience.

April 23, 2025 · 17:42 CDT
Monitoring

We are currently aware of an issue impacting email delivery. This appears to be related to an ongoing incident with our third-party email provider, SendGrid. Emails are being accepted and queued, but delivery may be delayed.

Our engineering team is actively monitoring the situation. We are in communication with SendGrid and will provide updates as soon as more information becomes available.

We appreciate your patience and understanding while we wait for resolution from SendGrid.

April 23, 2025 · 16:58 CDT

← Back